DIY calculator: HP30b to WP34S!

Posted: 2/25/2018 9:10:48 PM
dewster

From: Northern NJ, USA

Joined: 2/17/2012

Eamoex, here's a page out of my engineering notebook from back then:

Is that clear?  If not I can translate it from the Klingon... ;-)

The process is fairly nuanced!  Wow, over 4 years ago...  Unfortunately I don't use the calculator much anymore because the keys are so unreliable, and am sadly calculator-less.  I find myself using a really old (Win 3.1? Win 95?) Symantec "SCICALC.EXE"; also the the WinXP calculator because it does HEX (but the infix notation constantly trips me up).  Tried the various free ones on my Kindle Fire 7 and didn't cotton to any, it seems I'll be forced to make my own calculator at some point.  I don't really even need programmability, just solid scientific functions and an easy to use HEX mode.  The WP34S is way overkill for me.

Anyway, I'd be interested in your take on your final result.  Good luck!

Posted: 2/26/2018 7:26:11 PM
Eamoex

Joined: 2/25/2018

"Eamoex, here's a page out of my engineering notebook from back then: Is that clear? If not I can translate it from the Klingon..."

laughing Haha! I didn't expect the full graphics. So these are your notes? Wow, very tidy, and with a nice hand, thank you very much! Not even mentioning your ability to find the thing 5 years later…

So yeah, I think it's pretty clear now. Thanks so much for helping.

I'll let you know how it turns out.

Posted: 3/1/2018 12:57:30 PM
Thierry

From: Colmar, France

Joined: 12/31/2007

"I think you should check out this new great RPN calculator: https://www.swissmicros.com/dm42.php"

 Checked out. Thank you, Martinot, for that finding. Now saving my pocket money for it... ;-) 

Posted: 3/15/2018 1:33:08 AM
John Dick

Joined: 3/13/2018

Nice, it feels good to see one of these things. ;)

Posted: 7/21/2018 11:45:44 AM
Eamoex

Joined: 2/25/2018

Anyway, I'd be interested in your take on your final result.  Good luck!

Okay. So. I finally got around to trying this. But no win here.

I managed to erase the firmware. The calculator is in a brick state right now.

As to flashing... It's easy to determine whether it is turned on just by probing battery port voltage; it drops to 2.5-ish when it's on. I've got the exact same rig than you, with the resistors, one battery out and the connection between serial and battery grounds. Response is erratic at best. I got a few "Invalid response" messages (two different kinds, which I unfortunately didn't bother put down on paper). Now I can't get anything else but "No answer / Cannot connect to WP34s" from WP34sFlash and "Cannot connect" from MySamba.

I switched batteries at one point when I noticed the one still in the calculator had been drained, showing just above 2v. That didn't make things any better.

I use Win7x64.

I have no idea what to do next. Any help is appreciated.

Posted: 7/21/2018 1:20:54 PM
dewster

From: Northern NJ, USA

Joined: 2/17/2012

"I have no idea what to do next. Any help is appreciated."

Eamoex, sorry to hear you're having trouble.

I'd do some sanity checking.  Plug the USB serial cable into your PC, pull one of the resistors and use the other end of the remaining resistor to form a loopback from TX to RX.  Fire up a terminal program like TeraTerm and type into it (with local echo off) to see if the characters come back with the resistor loopback, and don't with no loopback.  Check both resistors with a DMM or with the loopback to make sure they're OK.

They say the calculator in the erased state draws significant power, so don't leave batteries in it when erased.  Get some new batteries, confirm they are fresh with a DMM, and try it again.  You can access ground via the six pad programming port, so if you are dexterous enough you should be able hold a third wire there and program it with both batteries installed.

Perhaps it's possible to permanently brick it?  I don't know enough about the hardware.  I do wish there was more feedback during the programming process, the thing just lies there, presumably thinking of England.

Posted: 7/22/2018 7:34:28 AM
Eamoex

Joined: 2/25/2018

Woohooooo!!! We have a win right here!

I suspect it was either the batteries down or bad connection between grounds (edit: or both...). Anyway I followed your advice by using spanking new coin cells and connecting directly to ground pad of the programming port and after a dozen fails, it finally worked! The process is dodgy, but it is possible to flash the calculator in this way I confirm.

Thanks a lot for your help, absent this I would've given up at that point. Now, let me put those key stickers all right...

One more Q though: what's the difference between "calc.bin" and "calc_full.bin" (not planning to install the x-tal anyway)?

Posted: 7/22/2018 8:04:24 AM
Eamoex

Joined: 2/25/2018

Look at this bad boy. Now I'll check for myself how unreliable the keys are!

Posted: 7/22/2018 1:38:10 PM
dewster

From: Northern NJ, USA

Joined: 2/17/2012

Lookin' good, Eamoex!  Glad you finally got there!

"One more Q though: what's the difference between "calc.bin" and "calc_full.bin" (not planning to install the x-tal anyway)?"  - Eamoex

The README file says: "The "_full" variants contain precompiled library code and are recommended."  Their code docs aren't very useful and have stale info.  There should be explicit, step-by-step directions on exactly how to program it with a TTL serial cable.

I kinda wish I'd gone with the WP31S as I really don't need the full-blown WP34S functionality (I use it mainly for direct calculations, nothing programmable) though it has been interesting to play with the WP34S for a while, and I'm not sure the WP31S existed at the time.  IMO there's only so much you can practically do given the typically extremely limited I/O of a hand-held calculator, even if there's a small graphics screen of some sort.  The keyboard itself is too much of a bottleneck, and if that's flakey...

"Look at this bad boy. Now I'll check for myself how unreliable the keys are!"

Yes, please report back.  Maybe they worked on this & fixed it in the newer firmware?  I don't get double entries on My WP34S, the error is missed keystrokes.  If you can't trust an entry to happen correctly when the tactile feedback happens then you've got to watch it like a hawk and double / triple check it constantly, which is just way too much babysitting to ask of the user IMO.  I mean, what if an accountant's calculator dropped random keystrokes?  Or a touch typist's keyboard?  It's just unacceptable.

I need a good HEX mode too.  One would think with all the software types out there that someone would make a basic, decent scientific / programmer's calc.

You must be logged in to post a reply. Please log in or register for a new account.