Couple of new minor forums features added...

Posted: 8/11/2005 3:32:46 PM
Jason

From: Sammamish, Washington

Joined: 2/13/2005

I'm home sick today (blech), so what better to do than work on the forums backend ;)

Anyway I added some simple formatting commands to the forums first. You can [b]bold[/b] or [i]italicize[/i] posts by surrounding words with [ b] and [/b] for bold and [ i] and [/i] for italics (no spaces, I had to do that for illustrative purposes).

You can insert links with [ url] and [/url] (again, no spaces). Here's an example:

[ url=http://www.thereminworld.com]Theremin World[/url]

Removing the spaces after the "[" characters, this would render in the forums like:

Theremin World (http://www.thereminworld.com)

Or, if you want to show people what the link is, just skip the friendly name part and put the URL between the brackets:

[ url]http://www.thereminworld.com[/url]

would render like:

http://www.thereminworld.com

Give it a try and let me know if you have any problems.

You can also now edit your own posts. Just click the "edit" link at the top of each message. You can only edit posts you have made (and I can edit them all, so keep it clean :)

As always, please let me know if you run into any problems caused by these changes.
Posted: 8/11/2005 7:19:09 PM
Jason

From: Sammamish, Washington

Joined: 2/13/2005

I forgot to mention, I got rid of some of the banner ads too - more screen real estate for content :)
Posted: 8/11/2005 11:01:51 PM
Jon B

From: Somerville, MA

Joined: 8/11/2005

The tags show up as plain text on Bloglines. i.e., they don't make things bold or generate a hotlink -- they just display as they were typed in.

Also, Jason, if you could get the poster's name in the RSS feed, that would be awesome.
Posted: 8/11/2005 11:06:02 PM
Jason

From: Sammamish, Washington

Joined: 2/13/2005

Ah, thanks for pointing that out. I forgot to update the forums newsfeed generator to do the same formatting.

I think I have both issues fixed now. It might take a while for Bloglines to re-sync my feeds, but let me know if it's still not working right.
Posted: 8/11/2005 11:37:29 PM
Jason

From: Sammamish, Washington

Joined: 2/13/2005

Just a quick test to see if links (http://www.thereminworld.com/forum-rss.asp) are picked up properly on Bloglines.com.
Posted: 8/12/2005 2:07:24 AM
Jeff S

From: N.E. Ohio

Joined: 2/14/2005

Thanks Jason. I appreciate both new features...especially the "edit" feature. There've been many times in the past when I wish I could have corrected a misspelled word or rephrased a sentence.
Posted: 8/12/2005 5:28:44 AM
Jon B

From: Somerville, MA

Joined: 8/11/2005

Links and credits both look great, Jason. Thanks!
Posted: 8/12/2005 8:35:14 AM
DiggyDog

From: Jax, FL

Joined: 2/14/2005

Thanks for all your work.

We love the site!
Posted: 8/12/2005 9:34:13 AM
Jason

From: Sammamish, Washington

Joined: 2/13/2005

Hey... forget about it ;) If you're happy, I'm happy. Just let me know what else you want to see here.

If you [i]really[/i] want to thank me, visit a few of those Google ads.

cheers,
-Jason
Posted: 8/12/2005 10:33:27 PM
Jeff S

From: N.E. Ohio

Joined: 2/14/2005

Jason - I tried to edit my message of 8/12 above to correct a misspelling. I made the change and clicked on "Save Changes". I was sent to a really old thread from 2003 and when I checked the changes did not take.
Just thought you'd like to know.

You must be logged in to post a reply. Please log in or register for a new account.