Website Updates

Posted: 9/27/2015 9:17:40 AM
Jason

From: Sammamish, Washington

Joined: 2/13/2005

Greetings Theremin friends!

After months of coding late at night and during my bus commute, I've finally finished some major website updates and deployed them tonight.  Here's a quick rundown of the changes:

  • New mobile friendly responsive layout
  • New magazine-style layout for articles
  • Improved ability to find articles in a specific category
  • Requires IE9 or higher
  • Profile images can now be 256x256
  • Nicer user profile pages with shorter URLs
  • More social sharing options for articles
  • Article images format nicely when shared via Twitter, Facebook and other social media sites
  • Better navigation in forums - entire row is now clickable
  • New "Popular Articles" section on many pages
  • Lots of little bug fixes

Please post back to this thread if you find any problems.  I'm sure there will be issues, but hopefully most of them are cosmetic.  You'll notice a few tweaks here and there as I update content with featured images and rearrange some of the menus.

The decision to require IE9 or higher was a tough one. For those of you who have known me a long time, I actually worked on IE4,5,6,9,10 and 11 while I worked at Microsoft.  But old browsers have many problems, and systems that won't run IE9 have major security risks.  So it's really time to upgrade :)

I have a few more updates and additions in development now, but I'm always open to your suggestions for how to make Theremin World better for theremin enthusiasts around the globe!

-Jason

 

Posted: 9/27/2015 9:55:58 AM
randy george

From: Los Angeles, California

Joined: 2/5/2006

Way to go Jason!! The site is looking really great!  Thanks so much for your hard work.   Usability, Form and Function, A++, my kind of web experience!  Also, it was fun contracting/expanding the browser window and watching the site layout dynamically adjust :)

 

Posted: 9/27/2015 6:39:55 PM
Jason

From: Sammamish, Washington

Joined: 2/13/2005

Thanks Randy!

Here are a a couple bugs I'm already working on fixing:

  • The search box doesn't allow spaces except on mobile devices (thanks to Randy for calling this one out)
  • The paging control in the forums is not right-aligned

If you spot any other issues, please just post back to this thread.

Update: 9/28 evening - I've fixed the 2 issues above.  I also tweaked the spacing on the menu bar for mobile phones. Please let me know if you see any problems with the search box in particular, as the solution was a bit "hacky" in my opinion.

Posted: 9/28/2015 8:36:41 PM
RoyP

From: Scotland

Joined: 9/27/2012

Nice clean make-over.

Looks good :-)
Thanks for your hard work Jason.

Posted: 9/28/2015 8:43:35 PM
dewster

From: Northern NJ, USA

Joined: 2/17/2012

Jason, thank you so much for all the time you put into TW, the new changes look quite nice!

 

I have a request: could you make individual forum posts addressable via url?  

Something like this:  http://www.thereminworld.com/Forums/T/31188/website-updates?post=5

Posted: 9/28/2015 11:26:06 PM
Jason

From: Sammamish, Washington

Joined: 2/13/2005

Thanks for the feedback!

Dewster, this has been on my list for a while. I need to solve a design issue for how to deal with the situation when I delete a spam post so that any links to subsequent posts don't change.  I'll bring this back to the top of the priority list and see what I can work out.

Posted: 9/29/2015 7:17:27 AM
Jason

From: Sammamish, Washington

Joined: 2/13/2005

Done.

Forum posts now have a little link icon in the lower left.  If you copy that, you'll get a URL directly to the post.  I also updated the email notifications to contain this link directly to the post, as well as the "Recent Forum Posts" section on the main page.

Here's the URL to dewster's post as an example:

http://www.thereminworld.com/forums/T/31188?post=209086#209086

I don't like exposing post IDs, but if I deleted or approved a forum spam post that had non-spam posts after it, then the order of the posts would change, so I couldn't use the 1.2.3... numbers.

I also applied some new styling so that large images included in forum posts will scale down correctly and not break the site layout on mobile devices.

Posted: 9/29/2015 9:10:46 AM
randy george

From: Los Angeles, California

Joined: 2/5/2006

Awesome! That feature request and your post reply would've earned a "Like" each (from me at least).  I know you previously mentioned that the "post liking" feature was in the pipeline.  I think it would be greatly appreciated and well used.

Posted: 9/29/2015 1:25:41 PM
dewster

From: Northern NJ, USA

Joined: 2/17/2012

That's what I call fast service!  Thanks Jason!  

Posted: 9/29/2015 1:32:39 PM
Jason

From: Sammamish, Washington

Joined: 2/13/2005

It appears that in my haste I broke the link in the forum update emails. I'll get that fixed up this evening.  The link will take you to the thread, but not the right post.

You must be logged in to post a reply. Please log in or register for a new account.