Adventures in Linux Land

Posted: 9/26/2019 2:45:39 PM

From: Northern NJ, USA

Joined: 2/17/2012

Scanner & Python & Audio

Got my scanner working.  I first tried version 3 for Ubuntu 18.04(LTS) located here: but it didn't work for me.  Uninstalled that, did the following:

Scanner (Epson Perfection 1660):
- Go to:, search for "perfection 1660"
- Get file: iscan-bundle-2.30.4.x64.deb.tar.gz
- Extract to Download dir.
- Console: navigate to ~Downloads/iscan-bundle-2.30.4.x64.deb/, s/b "" there.
- Console: sudo ./ --without-network
- This also installs a somewhat older version of GIMP!
- Installer: uninstall old version of GIMP, install version 2.10.12 (latest stable).

One of the reasons for my switch to Linux was to have Python 3 support (WinXP only goes as high as v2).  But invoking it on the command line pulls up Python 2:

Make Python 3 the default, install Tkinter:
- Console: update-alternatives --remove python /usr/bin/python2
- Console: sudo update-alternatives --install /usr/bin/python python /usr/bin/python3 10
- Then install Tkinter (if it isn't): sudo apt-get install python3-tk

I had to enable audio loopback to monitor the D-Lev via my PC (GUI mixers are one thing SW types seem to really mess up):
- Console: "alsamixer"

Believe it or not, the above took me several hours.  There is no locally installed help for GIMP 2.10.12, and I spent maybe another hour looking for it only to discover it doesn't exist yet.  Ah, well, it's all free.  Ubuntu 18.04 LTS has been really stable so far.

Posted: 10/1/2019 4:12:28 PM

From: Northern NJ, USA

Joined: 2/17/2012

PDF Image Extraction

One thing that I've fought with many times in the past is extracting images from a PDF file.  I want the native resolution, not something interpolated.  In a perfect world, I'd like the original image in it's native file format.  My method in the past was exporting from an old version of Adobe Acrobat, but even then it would ask for a target resolution and file format, so bleah. 

Well, the other day I was searching the web for just this issue and ran across "pdftohtml" which comes pre-installed in Ubuntu.  Wow, out pop all the images in their native format!  And it claims it can bypass PDF security.  Finally a solution here.  I used it yesterday to extract PDF sheet music pages, then I cleaned and cropped them in Gimp, and pasted them into a WPS Writer document in booklet format.  The whole process worked like a total champ (once I figured it out).  So far, WPS Office is amazingly compliant with MS Office, much more so than Libre Office.  Too bad it isn't open source, they'd put MS out of business.

Discovering and working through solutions to things I've done for years in XP is really climbing a mountain.

Yesterday my wife's Ubuntu PC booted to a black screen.  I reset it, it booted to GRUB, I selected normal boot, it said it was repairing the OS, then Ubuntu came up as usual.  Not sure what happened (she's not all that demanding of a PC user) but I'm glad it resolved itself.

Posted: 10/14/2019 8:04:22 PM

From: Northern NJ, USA

Joined: 2/17/2012

WPS Office Free Version Found Wanting

Just unpleasantly discovered the free version of WPS Office Spreadsheet doesn't support VBA, nor does WPS Writer support mail merge.  The universe is telling me it's time to get away from all MS Office-based products.  VBA in Excel was always super ugly and almost more trouble than it was worth.

Posted: 10/26/2019 4:21:24 PM

From: Northern NJ, USA

Joined: 2/17/2012

Linux Mint (distro hop imminent?)

As I've likely stated before (not trying to toot my own horn or bore you!), I do a bit of tech support on the side, and one person I do this for was my very first "Adventure in Linux Land".  Several years ago her laptop overheated and died (very poor thermal management HP!), was doooog slow in the first place, and her eyesight was starting to go, so I built her a low-end AMD desktop with a big monitor.  To avoid the "Microsoft Tax" I decided to give Linux Mint a go.  It was touted as the most "Windows-like" and had good reviews, was based on Ubuntu (as many distros are), and was quite popular (important).  It popped right up after a completely painless and quick install.  The printer install afterward actually gave me more trouble than anything else, though I was an almost complete noob to Linux (I knew "ls -l" from my X-windows days back in college, but that's about it) so the whole thing scared me a bit.

Anyway, armed with my newfound Linux knowledge, I had to go over and help her with her PC last week.  While I was there doing a SW update and other stuff I took note of how nice the Mint "look and feel" was, even on the older release, which piqued my interest.  So yesterday I got the latest Mint ISO (19.2 Cinnamon 64 bit) via torrent, burned it to DVD this morning, and gave the "live disk" a spin for an hour or so.  Wow, really nice experience right out of the box!  Launch bar on the bottom (as god intended), logically laid out start menu, no stupid "apps screen" like in Ubuntu, the Nemo file browser has all the options to make it look very much like the Win file browser, the package manager appearance is much more polished, etc.  In all, it doesn't feel like it's trying to be an OS for all occasions (look the same on a PC / tablet / smartphone / etc.) like Ubuntu, but instead highly targeted and honed to the PC desktop.  An MSWin user might feel 75% right at home with no setting changes, 90% with a few minor setting changes, with no add-ons or tweak tools + hours of farting around like Ubuntu requires.  MS did some things really right with Windows (before they proceeded to blow it IMO).

I'm getting this ominous feeling that I'll be jumping the Ubuntu ship quite soon (lord help me!).

[EDIT] Just ordered this sleezer SSD for a longer (possibly permanent) trial of Mint:

If I end up sticking with Mint I may clone it to my Samsung 860 EVO 500GB SSD (which currently has Ubuntu on it).

Posted: 11/1/2019 1:55:04 PM

From: Northern NJ, USA

Joined: 2/17/2012

This Transmission Is Coming To You...

Via Linux Mint!  SSD arrived in the post yesterday so I swapped my Ubuntu SSD out with it and installed Linux Mint 19.2 via "live" DVD.  The file copy took ~10 min, SW install took ~5 min, so maybe ~20 min to the first reboot.  Then, like any version of Win you run the update manager and it re-installs just about everything, but unlike any version of Win, this only took another ~15 min (a Win7 install & update can take several hours, usually taking a day or more to really be completely updated - thanks to .NET and the lack of service pack roll-ups).

For Ubuntu, to make the desktop seem like less of a "toy" I had to customize it with several tweak packages (Gnome Tweaks, Dash to Panel, Arc Menu, Clock Override) but Mint comes right out of the box looking pretty "Windows-y" and the built-in tweaking controls entirely adequate to fine tune things to the way I like.  Adding tweak packages after the fact can be problematic, moving / hiding essential buttons, odd behaviors, etc. so it's nice to have them ship with the OS where they've been integrated and tested more.  There are even tweaks to fix the too narrow width and "warping" behavior of the scroll bar (!).  Turning off the screensaver "curtain" screen in Ubunut and replacing it with powering down the monitor is a huge pain in the ass, with Mint it's just a couple of setting changes.  The only thing I had to download a tweak for was the numlock key - for whatever reason Linux has been forever plagued with not having the numlock on by default after boot.

Transferred my 20 or so years worth of email over to Thunderbird, imported my bookmarks to Firefox, got the printer and scanner working, installed WPS Office, and then started playing around with it to see what was pre-installed, trying stuff out if I was unfamiliar with it, adding SW that I preferred or was missing, etc.  Only thing I haven't installed yet is Quartus.  For some reason getting not-quite-the-latest version of Gimp was a gigantic hassle (the very latest seemed broken) but that's not a fault of Mint.


Install from live DVD session, do updates during this (have wireless working in the live session before install). 

Initial settings:
- Turn off system snapshot
- Run update manager: 91 updates, 470MB, ~15 min
- Layout: Traditional
- System Settings | Power Management | Turn off the screen | 15 min
- System Settings | Screensaver | Never
- Numlock isn't on!!:
  sudo apt install numlockx
  System Settings | Login Window | Settings | Activate Numlock
- Right click background:
  - Icon Size | Small
  - Auto-arrange | off
- System Settings | Themes | Window borders | Mint-Y-Dark
- System Settings | Themes | Icons | ubuntu-mono-dark
- System Settings | Themes | Controls | Mint-X
- System Settings | Themes | Mouse Pointer | DMZ-White
- System Settings | Themes | Desktop | Linux Mint

Fix scroll bars:
- System Settings | Themes | Settings | Jump to position when clicking in a trough | off
- System Settings | Themes | Settings | Use overlay scroll bars | off
- System Settings | Themes | Settings | Override the current theme's scrollbar width | on
- Ctrl+Alt+Esc will restart Cinnamon with the updated settings

Can't see secondary 1TB drive:
- Start Menu | Disks | (gear) | Edit mount options | User Session Defaults | Off (& edit)

- Uninstall Gimp (right click in start menu)
- sudo apt install snapd
- logout
- sudo snap install gimp (this installed GIMP 2.10.12)
- sudo snap refresh gimp --edge
- sudo snap connect gimp:cups-control

Misc Installer Software
- MediaInfo
- LuckyBackup
- Brasero (DVD burner)
- Audacious (Settings | Appearance | Interface | Winamp Classic)
- GSmartControl


So, unless some major nasty raises it's ugly head soon, I'll give Mint a spin for at least a few weeks.  If you're a Win person and are at all dissatisfied with the current state of affairs there, buy an SSD and give Mint a try.

Posted: 11/6/2019 3:39:52 PM

From: Northern NJ, USA

Joined: 2/17/2012

And Now For A Little Vino

Just installed Wine (Windows XP/Vista/7/10/etc. emulator):
- use package manager, install "Wine" (Wine installer)
- from console do config to give drive access, etc.: winecfg

Totally painless.  Don't follow any other web instructions (I did and they didn't work).

Up and running LTSpice in it!  Directory display is a bit wonky, but LTSpice itself has always seemed a bit wonky.

[EDIT] Installed Office 2003 Pro under Wine.  Word opens stuff fine but can't connect to Excel to do a mail merge.  Excel screens are all jumbled. 

Ah, probably just as well, I need to completely ditch MS junk.

[EDIT2] Just cloned the experimental 240GB Crucial drive (which has my current Linux Mint install on it) to my older 500GB Samsung 860EVO drive (which had Ubuntu on it - sorry Ubuntu!).  ~20 minutes in the Sabrent USB cradle (which has an auto-clone button) while I played solitaire on my tablet.  Booted right up, manually expanded the partition in via the "Disks" application in Mint, which took all of one second.  At this point, were this Win7 or Win10, it would be demanding that I re-register the OS as genuine (homey don't play that game anymore - sorry MS!).

Posted: 11/12/2019 3:23:59 AM

From: Northern NJ, USA

Joined: 2/17/2012


Timeshift is pretty amazing - I've used it three times today!  Restores the system (not personal files) to whichever snapshot among the various ones you've got saved.  Like an idiot I turned it off initially, glad I turned it back on before I really started experimenting.  Got it set to store one snapshot per day.  With it to fall back on you can go pretty crazy playing with the system.  Takes all the fear out of messing with things.

Posted: 12/4/2019 7:21:59 PM

From: Northern NJ, USA

Joined: 2/17/2012

"De-Chroming" An Acer C720-2827

Over the holidays I scored an older but pristine Acer Chromebook.  I've had very little experience with it, but Chrome as an OS seems like it kinda sucks!  Like the Chrome browser, settings are super hidden and the whole thing is dumbed down way past the point of improving the user experience.  Entering "developer mode" takes forever!  Anyway, here comes another install of Linux Mint 19.2!  I also upgraded the SSD from 16GB to 128GB for $25 USD.

It's funny, I've been saying forever that something like a Chromebook (simple computer with locked-down OS and BIOS) has been totally necessary for the masses.  Now that I encounter it I don't think that so much.  Is it poor implementation, or is it just me?  Dunno...

Pix please:

Above: Closed.  It's really small!  11.6" screen.

Above: Open and running Linux Mint 19.2.  Sweet!  Hey, where's the delete key?  And who decided to rename the function keys?  Google's just gotta pee on everything, even if it's an obvious step backwards.  Note security tape over camera (use blue painter's tape, it doesn't get old and cracky and leave a gooey / crusty residue).

Haswell Celeron 2995U. 1.4GHz, dual-core, 2MB Cache
2GB DDR3 (not upgradeable)
11.6" TN 1366x768. 220 nits
16GB SSD (NGFF M.2 connector)
HDMI port, 1 x USB 2, 1 x USB 3, SD slot (SDXC compatible)
Headphone/mic combo jack
Camera & mic
WiFi: 802.11 a/b/g/n

SSD (M.2 SSD 2242 NGFF SATA) from 16GB (Kingston) => 128GB (KingSpec):
1. Boot, install recovery app from Chrome Store.
2. Storage target SD card (USB thumb drive backed up OK but no response at restore).
3. Swap SSD drives (remove BIOS write protect screw while you're in there).
4. Power down, ESC + refresh (F3) + stab pwr button.
5. Insert SD card, recovery starts.

BIOS (instructions here:
1. Power down, ESC + refresh (F3) + stab pwr button.
2. CTRL + d, enter, *wait* (>15 min!).
3. "Let's go"
4. Connect to WiFi.
5. Accept & continue.
6. Browse as guest.
7. CTRL + ALT + t (brings up terminal).
8. cmd: shell
9. cmd: cd; curl -LO && sudo bash
10. Option #3 (full ROM), do backup to thumb drive!
11. After done: 'P' to power down.
12. Reinstall laptop back.

Linux Mint Cinnamon v19.2:
1. Download ISO to other Mint/Ubuntu PC.
2. Run USB Image Writer, pick ISO & thumb drive.
3. Plug thumb drive into Acer, boot, type "exit" to go to BIOS.
4. Configure to boot from USB.
5. Boots to Mint, do install.
6. Do nit-picky customization until you're satisfied with the way things look & feel.
7. Install apps, browser extensions, etc.

Took me a while to get it to recognize the new larger SSD I bought for it: the recovery process didn't want to work from my thumb drive so I had to use the SD card from my camera.  In the process got to see how much Google is tracking me!  All of my web bookmarks from my main PC transferred over during the "sync" operation, which was really creepy as I hadn't realized I'd ever enabled that - and of course I never did: Google is like Facebook in that you have to explicitly "opt-out" of all their spying and data gathering and such, and the many separate procedures to do that require a fair bit of research, and who knows if you did them all and did them correctly, or if they ever really erase anything on their end.  Google can suck it.

How "fast" is this laptop?  It's definitely slower than my desktop PC, which is also a older dual core, but at least it ain't no sleazy ol' Celeron.  It's certainly usable though.

Were I to do it again (knowing what I know now) the whole thing would only take a couple of hours.  The reason this Chromebook ended up in my hands in the first place is Google ended support for the OS a while back.  So much perfectly decent HW in landfills due to unmaintained SW.

Posted: 3/22/2020 4:32:08 PM

From: Northern NJ, USA

Joined: 2/17/2012

No Regrets

I don't believe this is entirely my growing distaste for MS (or Apple) talking, but even with the highly inconvenient lack of support for essential file types, and so a lot of my previous work ended up in data graves, I can't say I miss the paid OS world at all.  Something I couldn't have foreseen, and almost don't understand now, is my feeling of certainty that the sustained benefits of using Linux strongly outweigh the very real and painful costs of switching to it.  Every time I open Win10 on the laptop I find myself more and more repelled by it - it's clearly written by joyless drones, overseen by clueless MBA's intent on killing the golden-egg-laying goose.  Windows schedules all updates at startup / shutdown (or both!) which is the absolute worst time to do them.  Some blend of XP and Win7 (but not Vista!) would have been a good long-term mooring place for Windows IMO. 

I'm largely fine with Firefox for browsing, Thunderbird for email, Gimp for photo editing, etc.  But what I still need to address is: what to word process and CAD in so that I don't end up here again at some point in my life?  What file formats are the most future-proof here?  LaTex editors seem half-baked, the environment itself is gigantic, and the results less than spectacular unless you're writing research papers.

It would be really great if the open SW community could declare one word processor & one 2D/3D CAD tool their permanent "focus" and devote the bulk of their efforts to that.  The abandonment rate of SW, even paid SW, is alarming.  I think a lot of the churn is underlying, there seems to be a need to jump from one GUI manager to the next every year or so.

Posted: 8/3/2020 4:48:08 PM

From: Northern NJ, USA

Joined: 2/17/2012

Linux Mint v19.3 => v20 (2x with mixed results)

A month ago the Mint people offered an automated upgrade from version 19.3 "Tricia" to 20 "Ulyana" (both are long term support), and this was announced via an icon in the system tray with a link to web instructions.  I held off for a while as it seemed many were having not so minor issues with it.  A couple of weeks ago I applied the automated method to my de-Chromed Chromebook (described above) and it took a couple of hours but it all went very well.

Yesterday I got a wild hare (hair?) up my ass and decided to upgrade my main PC.  I backed up the hard drive, created a restore point, removed the packages it was complaining about, and finally ran it, and a while later my system rebooted but it deposited me to a rudimentary grub command line.  No instructions on the web (that I could find) could get me around the problem by typing stuff in.  The method that seemed to work for most was to download the v20 iso file, burn it to a USB thumb drive as a "live" disk, boot to that, and proceed from there.  My wife's PC runs Ubuntu, and it has a built-in tool to burn "live" iso to USB, so ~20 minutes later I was booting to that on my otherwise bricked machine.  The Linux Mint "live" iso has a "boot repair" option in the start menu so I ran that, and a few minutes later I was able to boot off the upgraded v20 on my hard drive.  A bit of reinstalling stuff later and I'm back in business (but what was I thinking?).

You must be logged in to post a reply. Please log in or register for a new account.